Battlegear Mod For Minecraft 1.8/1.7.10/1.7.2/1.6.4

Battlegear Mod is outstanding and excellent, which helps you get interesting weapons. Battlegear Mod add new weapons system, press ‘I’ button or click on the character you play in the screen, It will bring up the Weapon Inventory Screen. Weapons that can be placed in the main hand or off-hand. These weapons will appear on your play style when you go into third person view, Battlegear Mod is an amazing weapon, this can switch between the shell and painted by pressing ‘R’ button. Items listed in the following table will be able to stay in the weapon. There is an option in the config file to use weapons from other mods is my view on this mod is pretty good.

Battlegear Mod

Battlegear Mod Main Features

However, this series is a contribution that was made a long time and this time, many developers streamline and blend works better in this new version. We call it “Mine & Blade: Battlegear 2 Mod” If you continue to love and a favorite of this mod, or you are real fans the mod. You can download the original version on the download link below. And if you want to track new version. You can download it from the link below as well. It will link you to the new web page. With a link, you can download and install Battlegear Mod.

Battlegear Mod

How to Install Battlegear Mod

  1. Download and Install Modloader
  2. Download and Install PlayerAPI (If using Single Player Commands, install the player API-SPC patch)
  3. OPTIONAL (For dyable Shields) (Download and Install Minecraft Forge)
  4. Download Battlegear Mod
  5. Place the downloaded zip file in the mods directory in you’re .minecraft directory
  6. Take the fight to the creepers!!

  • MasterOfSwords1

    This doesn’t work

  • officialnerdcubed

    it doesnt work

    • http://www.skyrimdl.com/ Admin

      Please check you version before install this.

  • http://www.skyrimdl.com/ Admin

    Thank for help us for check this mod, we will fix it as soon as possible. So, if you can find look like the link or you think it can compatible with this mod, just show you link.

  • INEEDHELP

    When i skip advertisement, it redirects me to a page, i click on free download, and nothing happens, HEEELLLPPPPP !!!!!

    • http://www.skyrimdl.com/ Admin

      Listen me step by step again
      1.When you step through adf.ly, just go to skip!
      2.Okay guy, you will find that new page, and look at free download! then just wait a few second. So, just press button. You will found next page again
      3.Please look at the small font. It’s look like this >>> DOWNLOAD <<<<.
      4.Done!

      • http://www.facebook.com/boyd.billy Boyd Billy

        where is the small fonted Download

      • http://www.facebook.com/boyd.billy Boyd Billy

        where is the small fonted Download

  • http://www.skyrimdl.com/ Admin

    Do you want to get download Modloader right? Just search in top page.

    • Romy

      hey if i have modloader and forge all in one they don’t work together or forge or modloader not all on one!!!!

      • http://www.skyrimdl.com/ Admin

        um….Please show me, Just capture page….I would like to see more..

  • kkbro

    hi my minecraft just get a black screen what should i do i have deletet METAINF

    • Admin

      Wait

  • yo

    Its not working. Why?

  • jojo

    :) the figt to creepers is won

  • why

    i click download-addfly-then i see “FileCopter” and it won’t download! how do i get past filecopter????

  • dbsprite

    how do i download from the helicopter site?

  • alphamike99

    hey, i followed the steps and all but when i open minecarft it crashes? it’s the modloader causeing this. how do i get the mod to work

  • elvishwarlord

    hey dude, i have the same problem, yeah why does it do that??

  • Timothy

    IT DOESNT FREAKING WORK

  • Dean Harrington

    guys this mod was discontinued in october 2012 it was in minecraft 1.2.5 it dosent work now becuse 1.4.5 and below mods dont work with 1.4.7

    • http://www.skyrimdl.com/ Admin

      Thank for help us! I will test this version….If cannot work. I will tell u again

  • havardur

    may you have to delete META-INF

    • AWESOMENESSKING

      come on guys, you ALWAYS have to delete META-INF to install mods

  • sebaleb

    so it wont work for 1.5.1?

  • David Handorf

    can you update to 1.5.1

    • Experienced Crafter

      Can’t. The actual Battlegear mod is only on 1.4.7. The creator is working on Battlegear 2 for 1.5.2, but that can’t be gotten until he releases it.

  • dood u dont know

    wheres the download

  • Cockman

    Doesnt works for Forge -.-, Mod Loader and Forge doesnt work togheter and Mod Loader SUCKS!

  • juan

    it doesnt work!

  • Herce1111

    no me funciona el mod

  • Zap

    I’m not sure if you know this but i found out this mod requires Player API. its another mod. download API for the version you have and try it

  • Cookie

    What MC version is this for?

  • bjaibd

    where do you download it?

  • My Ass

    I dont get this mod AT ALL